This is a post intended to help out others who may have run into errors during the installation or post-installation running of the DTrade IBM Forms Viewer (the IBM Forms Viewer – latest version 8.0.1.1 from DDTC is here). If you’re seeing errors mentioning “Netscape_listener” or other listeners then you probably have Firefox installed on your computer and, in so doing, have prevented the Forms Viewer from running properly. As unbelievable as it is, the fix for this is to completely uninstall Firefox and then the Forms Viewer should work perfectly (meaning .xfdl forms and the attachments within them will utilize Internet Explorer).

This is an unfortunate situation for those of us who enjoy using Firefox. Of course, if you are doing ITAR work and need to prepare and submit licenses to DDTC, then you currently have no option but to uninstall Firefox so that the Forms Viewer works properly. The only other solution would be to keep Firefox installed but install Forms Viewer in a Windows virtual machine that doesn’t have Firefox installed on it. For me, this is too extreme a solution. I truly hope DDTC or IBM can fix this with the next release of the Forms Viewer.

15 thoughts on “DTrade Form Viewer and Firefox Incompatibility

  1. Strange as this sounds, it’s true. I was getting an error that mentioned “Netscape_listener” when using Forms Viewer 8.0.1 and couldn’t figure out why. I’d reinstalled Forms Viewer but kept getting it. Sure enough, after I uninstalled Firefox, the forms viewer started working just fine.

  2. Thanks for chiming in, Leo. It’s good to know I’m not the only one with this problem, and I am disappointed that I can’t have Firefox installed on the same machine I use to do ITAR licensing work (unless I run it in a virtual machine).

    I really hope that DDTC and/or IBM release a new version of the Forms Viewer without this compatibility issue.

  3. Can across this post and wanted to thank you for posting. After uninstalling Firefox I could then run IBM Forms Viewer. Before I would just get cryptic error messages.

  4. WOW- I can’t tell you how thankful I am that a) you wrote this post and b) that I managed to find it! I was getting 6-7 error messages one after another each time I tried to open a form, and had tried everything I could think of to troubleshoot the issue. However, I NEVER would have imagined that Firefox was the culprit! Thank you so much for taking the time to share this–you saved me many hours of frustration! On another note, I find it odd that the documentation (FAQs, install guide, etc.) on DTRADE doesn’t mention this incompatibility. It does point out that you can’t use Firefox for the submission process, but no where does it say you can’t even have it installed on your machine! So bizarre. Thanks again!!

  5. You’re very welcome! Thanks for letting me know that the post helped you out. I am still disappointed that I can’t use Firefox on my laptop due to this issue with DTrade

  6. Spent well over 2 hours trying to diagnose what was wrong with this form viewer due to that rather obscure error message. Uninstalling firefox resolved it quickly – at the cost of creating problems for web apps which Firefox was required for. Thanks for the tip!

  7. I’ll add my thanks to the list! Much appreciate it. Frustrating that not only are we required to use an old version of IE to log in to DTrade, but we must also remove Firefox in order to use Forms Viewer.

  8. The Consolidated Screening list does not work in Internet Exporer correctly, so I cannot screen people from my computer and have to go from office to office to find some one who is running Firefox or Chrome and time to let me use their computer!

Leave a Reply

Your email address will not be published. Required fields are marked *